Aide formules Excel

9
26 juillet 2020Édité par:"Simsim50"
Bonjour, j'aurai besoin d'aide pour des calculs et formules avec excel
J'ai une colonne avec des variables Binaire : 1 ou 0 (corespondant à si 1 Femme et 0 Homme)
et une autre colonne : avec des chiffres (age)

je voudrais faire la moyenne, ecart type etc des ages chez les 1 et chez les 0

Si j'utilise le tableau croisé dynamique il ne prend pas en compte le 0

et j'arrive pas avec NB.SI ou SOMME.SI ; j'ai pas mal épluché le web mais la ...

merci
au passage j'ai aussi XLSTAT si y a des experts ! je veux bien pour la suite
Informations supplémentaires
Blabla
9 commentaires
Non ne fonctionne pas, j'ai un message erreur : "cette valeur ne correspond pas aux restrictions de validation des données pour cette cellule.

EDIT : j'avais des validaton de donnée sous forme de liste j'ai modifié
"Onglet Données - Validation de données
Remettre autoriser Tout"
Je teste de nouveau

=> merci j'avais une restriction à cause des validations de données ! merci pour MOYENNE.SI.ENS
Édité par "Simsim50" 26 juillet
Et si tu refaisais une colonne avec que les hommes et une autre avec que les femmes à l'aide de la formule Si ? (Si un homme mettre age sinon rien. )
Réussi ! merci
Nouveau probleme
je voudrais grouper des durées par tranche horaire

exemple : en H et minutes avec événement à coté

04:19:00 1
00:36:00 1
00:23:00 1
06:38:00 1

je voudrais regrouper les durée en tranche par exemple de 15 min pour pouvoir analyser les données brut et que se soit plus lisible et interpretatif

pour avoir un tableau ou courbe de ce genre
0 à 15 3 évenements
15 à 30 1 ....
etc


mais j'arrive pas avec le tableau croisé dynamique
j'ai regrouper en H et min
mais j'arrive pas a créer les tranches
une idée ?
Édité par "Simsim50" 9 août
Simsim5009/08/2020 12:48

Nouveau problemeje voudrais grouper des durées par tranche horaireexemple …Nouveau problemeje voudrais grouper des durées par tranche horaireexemple : en H et minutes avec événement à coté 04:19:00 1 00:36:00 1 00:23:00 1 06:38:00 1 je voudrais regrouper les durée en tranche par exemple de 15 min pour pouvoir analyser les données brut et que se soit plus lisible et interpretatifpour avoir un tableau ou courbe de ce genre0 à 15 3 évenements15 à 30 1 ....etc mais j'arrive pas avec le tableau croisé dynamique j'ai regrouper en H et min mais j'arrive pas a créer les tranchesune idée ?



Tu te fais une nouvelle colonne qui convertit ton heure en minutes que tu divises par 15 en ne conservant que la partie entière.
Exemple :
1h16 > 76min > 76/15 = 5.07 > 5
1h28 > 88min > 88/15 = 5.87 > 5
1h31 > 91min > 91/15 = 6.07 > 6
comment on fait pour les regrouper en catégorie ? j'ai plus de 500 lignes
je voudrais faire des colonnes par catégorie
0-15
15-30
etc


j'ai trouver cette formule sinon : =NB.SI.ENS(B1:B2;"1";A1:A2;"<00:15:00")
sommes des événements 1 lorsque le critères <00:15:00 est présent ?
avec 00:15:00 15 exclus

pour avoir la tranche au dessus je droit faire apres A1:A2;">00:15:00";A1:A2;"<00:30:00" ? puis etc
mais c'est difficilement gérable j'ai des 5000 minutes ...


difficile de ne pas automatise ca ... surement parce que je suis au forma durée et non chiffre dans les cellules mais je ne peux pas changer j'ai des aberations
Édité par "Simsim50" 9 août
Simsim5009/08/2020 13:54

comment on fait pour les regrouper en catégorie ? j'ai plus de 500 lignes …comment on fait pour les regrouper en catégorie ? j'ai plus de 500 lignes je voudrais faire des colonnes par catégorie 0-1515-30 etcj'ai trouver cette formule sinon : =NB.SI.ENS(B1:B2;"1";A1:A2;"<00:15:00")sommes des événements 1 lorsque le critères <00:15:00 est présent ? avec 00:15:00 15 excluspour avoir la tranche au dessus je droit faire apres A1:A2;">00:15:00";A1:A2;"<00:30:00" ? puis etc mais c'est difficilement gérable j'ai des 5000 minutes ...difficile de ne pas automatise ca ... surement parce que je suis au forma durée et non chiffre dans les cellules mais je ne peux pas changer j'ai des aberations



Avec mon histoire de nouvelle colonne tu regroupes juste par nombre entier identique et c'est tout.
Pastek09/08/2020 23:28

Avec mon histoire de nouvelle colonne tu regroupes juste par nombre entier …Avec mon histoire de nouvelle colonne tu regroupes juste par nombre entier identique et c'est tout.



super j'ai reussi
j'ai fais comme tu as dit.
Et j'ai trouvé mon soucis, j'avais les résultats en Cellule : standard et modifiant en Durée c'est bon, j'avais les bonnes moyennes.
Je voulais modifier la cellule source pour faire les calculs, alors qu'il fallait modifier les résultats
Édité par "Simsim50" 16 août
Laisser un commentaire
Avatar
@
    Texte