CTC Prusa I3

3050
7 octobre 2016
Bonsoir,

Ce topic est fait pour partager notre expérience sur l'imprimante 3D CTC Prusa I3 suite à ce deal: dealabs.com/bon…891.

contenu de la carte SD:
- dropbox.com/sh/…l=0

Firmware CTC prusa i3 d'origine
- dropbox.com/sh/…l=0
- Backup réalisé par Boubobo : dealabs.com/url…808
- Firmware à jour (21/11/16) pour vis filetées M8 : stuff.knackes.com/dld…zip
- Firmware à jour (21/11/16) pour vis hélicoïdales T8 : stuff.knackes.com/dld…zip
- faire son propre backup :
Acheter cet accessoire : amazon.fr/gp/…c=1
[spoilerLigne de commande (depuis le dossier bin d'arduino) : avrdude -C ..\etc\avrdude.conf -p atmega2560 -c usbasp -U flash:r:"d:/GT25]60.hex":i




- restaurer un backup :
Pour le restaurer : avrdude -C ..\etc\avrdude.conf -p atmega2560 -c usbasp -U flash:w:"d:/GT2560.hex":i
- le câbler :
stuff.knackes.com/dld…jpg
- injecter le bootloader: dealabs.com/dis…=67


montage:
- youtube.com/wat…MzY
- youtube.com/wat…_dk
- youtube.com/wat…Fcc

Le schema de montage de l'electronique de la documentation est faux, se référer à celui-ci:
1081156-hjsFD
- PDF : stuff.knackes.com/dld…pdf
- ODT : stuff.knackes.com/dld…odt

Régler la prusa:
- youtube.com/wat….be

Pièces updates (à imprimer)
- Support alternatif pour l'axe Z: thingiverse.com/thi…197 ou thingiverse.com/thi…485
- Ventilateur pour refroidir le print: thingiverse.com/thi…920 ou thingiverse.com/thi…016 ou thingiverse.com/thi…313 (compatible avec le ventilateur B5015L12C NF1 12 V 0.08A fr.aliexpress.com/ite…0_0,searchweb201602_2,searchweb201603_1&btsid=7f68fe54-379f-487d-8520-3b21c250feeb)
- Rigidifier l'axe Y: thingiverse.com/thi…317
- Cache alimentation: thingiverse.com/thi…851
- Poulie de remplacement: thingiverse.com/thi…392 ou thingiverse.com/thi…910
- Coupleur 5mm vers 8mm: thingiverse.com/thi…127
- patin anti wobble: thingiverse.com/thi…359
- Support ecran LCD déporté: thingiverse.com/thi…805
- Support endstop Z alternatif: thingiverse.com/thi…488
- Support capteur bed leveling: thingiverse.com/thi…547
- Support capteur bel leveler BLTouch de Geetech : thingiverse.com/thi…404
- cache prise alimentation: thingiverse.com/thi…093



Pièces détachées & consommables:
- Capteur pour le Bed leveling - Geetech: geeetech.com/wik…sor ou fr.aliexpress.com/ite…886 et tinyurl.com/jf8…lpm
- Coupleurs aluminium 5mm vers 8mm: tinyurl.com/hdq…6zd
- Tiges filetées Hélicoïdales T8x400mm avec vis: fr.aliexpress.com/ite…auM
- Ventilateur 12v : fr.aliexpress.com/ite…auM
- Roulements à bille pour le support de tiges filetées: fr.aliexpress.com/ite…GSZ
- Extrudeuse en aluminium : fr.aliexpress.com/ite…0_0,searchweb201602_2_10065_10068_10069_10017_10080_10082_10081_10060_10061_10062_10056_10055_10037_10054_10059_10032_10078_10079_10077_10073_10072_10070_421_420_10052_10053_10050_10051,searchweb201603_3&btsid=5d098298-e9c8-47f5-8d45-76f8413398a3&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476780765147-01149-mEj2auM (Attention, il semblerait que le support de l'extrudeur soit incompatible)
Tube téflon: fr.aliexpress.com/ite…auM
- Chaîne de guidage de fils: fr.aliexpress.com/ite…auM
- Poulies en aluminium : fr.aliexpress.com/ite…auM
- Buse: fr.aliexpress.com/ite…auM
- Gorge de buse: fr.aliexpress.com/ite…auM
- 3M ScotchBlue 2090-2A "BlueTape" : amazon.fr/dp/…DU/
- plateau aluminium : ebay.fr/itm…rue ou fr.aliexpress.com/af/…y=n (attention, pas de support de roulements)
- Bobine PLA pas cher: ebay.fr/itm…rue (couleurs rouge et orange fade, chauffe 195 à 2015°C)





Sites divers:
- calculer le nombre de steps/mm en cas de changement de tiges
- Rappel: motor step angle = 200 / microstepping = 1/16 / Tige de type M8
- prusaprinters.org/cal…or/
- Guide visuel : makershop.fr/blo…el/
- Parameter Slic3r: (ou au moins le moteur de l'extrudeur) velocirepraptor.com/par…le/
- Visualisateur de GCode en ligne gcode.ws/
- Visualisateur de STL en ligne viewstl.com/
- Octoprint:
- octoprint.org/
- velocirepraptor.com/ins…nt/
- velocirepraptor.com/uti…nt/
- aide sur la résolution de défaut d'impression : logre.eu/wik…tor




Merci à tous pour votre participation.
Informations supplémentaires
High-tech & informatique
3050 commentaires
Voila les photo

[image manquante]



[image manquante]



temps que j'y pense quand je lance l'instalation du logiciel il ne ce lance pas car dans le titre du logiciel il avait des caractere en Chinois
une fois suprimé le logiciel ce lance bien

au faite je suis le seul a pas trouver de lecteur de carte sd deriere le LCD ??
Mr_Pluch

@tension et @guilhem Oui, le moteur mis sur le connecteur d'un axe, il … @tension et @guilhem Oui, le moteur mis sur le connecteur d'un axe, il tourne correctement.Du coup je crois que je vais essayer ce que vous dites... Même si je ne comprends pourquoi il faudrait que je le fasse alors que les modèles de moteurs sont identiques. J'essaye demain. Des que je peux je te poste une photo boubobo, si tu n'en as pas eu d'ici là. J'ai essayé de recoller la pièce avec ce que j'ai... Superglue et colle epoxy.... Et bien ce n'est pas ce qu'il faut.


Beaucoup de carte d'imprimante 3D nécessite une branchement différent pour l'extrudeur.

Vu tes observations je mettrais ma main a couper que c'est un problème de branchement. Maintenant il y a trois solutions, tester toutes les combinaisons jusqu’à trouver la bonne, ou mesurer a l'ohm mètre entre chaque fil pour trouver le bon brochage et supposer que le soft est a peu pres logique (donc combinaison 1-2-3-4 ou 3-4-1-2, avec 1 et 2 les fils ayant une resistance faible entre eux et 3-4 idem), solutions 3 inverser les pins du moteurs dans le soft.
je te conseillerai de vérifier la combinaison 3-4-1-2 en premier.
Apres recherche
le petit boitier métallique ou on insert la carte SD a étais oublier sur mon LCD
je peut donc pas imprimer a partir de la carte sd
et le logiciel fourni ne détecte pas mon imprimante

15701495-YFLuI

Je devrais recevoir la mienne lundi ou mardi, mais en vous lisant, je commence a flipper . Au fait, c'est la poste qui vous a livré ou un autre transporteur?
Merci Beaucoup Zin27, ah oui il manque une pièce sur ton LCD !
Envoie tout de suite un message ebay au vendeur pour demander son remplacement, j'ai eut une réponse en 30 minute ce dimanche.
Pour le logiciel, je télécharge la dernière version de Cura sur le site officiel ( ultimaker.com/en/…are ), j'ai pas confiance dans les exe chinois

Pour la détection de l'imprimante il faut d'abord installer les pilotes série (FT232RQ) : ftdichip.com/Dri…htm
Merci Boubobo !!!
J'avais effectivement télécharger Cura sur le site officiel ,j'ai trouver facilement la Prisa I3 dedans
mais le pilote me faisait défaut , j'essaye ce soir en rentrant

Faut pas s’inquiète Tenson22
Le montage est pas super Compliquer au final

en mode préparation j'ai pu tester l'extrudeur , au début j'ai eu peur de trop rentré le PLA mais en faite faut appuyer un peu pour qu'il entre dans la partie qui entraîne le plastique
Mes moteur ne vont toujours que dans un sens mais j'attend de lancer un programme complet pour voir comment elle réagi
Mon premier retour après 1 weekend de trifouillage :

Le support de la poulie du plateau chauffant est cassé comme pas mal de monde j'ai l'impression, le vendeur va m'en renvoyer un, pour l'instant j'ai fixé avec de la colle et des vis, ça tient a peu près le coup...

Nombreux blocages au niveau des moteurs des vis, du coup j'ai laissé un peu de mou au niveau des couplages en plastique et j'ai bien graissé les vis, ça va un peu mieux, mais c'est toujours pas top du coup j'ai commandé des coupleurs en métal, j'espère que ça ira mieux

J'ai pu faire un premier test d'impression, mais ça s'est bloqué au milieu, à voir par la suite

Pour ceux qui ont des problèmes avec l'extrudeur, j'avais aussi quelques soucis, en fait il y a un vide entre le trou d'insertion et l'extrudeur en lui même et vu que le filament est légèrement courbé il ne rentre pas forcément dedans, du coup j'ai démonté le ventilateur sur le coté pour bien guider le filament dans le trou inférieur, maintenant ça marche

Question stupide, depuis l'interface de l'imprimante, j'arrive à déplacer les différents axes en négatif, mais pas en positif, vous avez une solution ?
Mr_Pluch

J'ai essayé de recoller la pièce avec ce que j'ai... Superglue et colle e … J'ai essayé de recoller la pièce avec ce que j'ai... Superglue et colle epoxy.... Et bien ce n'est pas ce qu'il faut.


Ouais l’époxy n'a pas tenu plus de 10 minutes sous tension, et je n'avais pas serré à fond. Je vais refaire un essai avec du fil de fer encerclant la pièce en plus de l’époxy

Conseil important : ne pas brancher les moteurs de l'axe y (le seul axe avec deux moteurs en parallèle) avant d'avoir vissé l'axe x (celui avec l'extrudeur) dessus : le fait de visser l'axe crée du courant et de toute évidence la carte mère le gère mal, j'ai vu l'écran LCD s'illuminer alors que l'alimentation n'était pas branchée. Ya un danger de flinguer la carte mère comme ça. Depuis j'ai débranché tout les moteurs, les instructions sur où il faut les brancher ont l'air fantaisiste de toute façon, je ferais ça proprement à la fin.

Quelques remarques
- le moteur de l'axe z (celui du plateau chauffant) est juste tenu par deux vis, qui chez moi ont déjà du jeu, j’ai peur que ce soit un peu faiblard.
- le trou "passe fils" du montant gauche (celui avec la carte mère) en haut, vous y avez mis quoi ? les nappes du lcd ou l'alim ? parce que les deux, ya pas moyen sans sortir le rabot !
- les tiges non filetés à monter verticalement faut y aller comme un porc, pensez à soutenir les moteurs Y quand vous les poussez dedans, car ils ne reposent sur rien à la base

Sinon j'en suis au montage de l'extrudeur, et je pense que c'est de ça dont parlait Mr_Pluch dans le premier post : on est bien d'accord que deux vis de 16mm ne suffisent pas ? C'est trop court et ça affleure à peine le support de l'extrudeur, c'est impossible à visser.
Il se trouve que j'ai des vis M3 de 20mm, je vais les utiliser car je trouve que les 30mm sont trop longues.

15701835-hk2YD

Autre question : il y a 4 trous dans le support de l'extrudeur, mais seulement deux trous dans le support de l'axe x : vous utilisez les trous du bas dans le support de l'extrudeur ? ?

Boubobo, je crois les avoir mis dans celles du haut, mais je ne suis pas sur à 100%, je te confirmerai ce soir si tu veux, de toute façon je ne pense pas qu'il y ait une grande importance vu que tu peux régler la butée de fin de course avec la grande vis sur la gauche.
twistedmind

...J'ai pu faire un premier test d'impression, mais ça s'est bloqué au m … ...J'ai pu faire un premier test d'impression, mais ça s'est bloqué au milieu, à voir par la suite ...



Pour ton blocage au milieu de l'impression, c'était un blocage matériel (genre un point dur, quelque chose qui force...) où ça s'est arrêté sans raison ?
Si ça s'est arrêté sans raison, 2 points a vérifier :
- ouvre le fichier .gcode de ton impression est vérifie qu'il est bien complet (genre, qu'il ne se termine pas par une ligne style S1 X... et rien d'autre après). Perso, j'utilise Slic3r et la fin du fichier .gcode contient les paramètres du fichier en commentaire (hauteur de couche, température...). J'ai eu quelques fois un bug lors du "slicing" et mon fichier .gcode n'était pas terminé : l'imprimante suit alors le fichier et s'arrête là où le fichier s'arrête.
- si tu imprimes en USB, essaye à partir de la carte SD : un mauvais cable USB peut causer des "timeout", ce que Repetier n'indique pas toujours. Dans ce cas, l'impression se stoppe directement.
Ok twistedmind, merci. De mon coté je trouve que même les 20mm sont limite : je peut mettre un écrou mais pas la rondelle, j'ai commandé des M3x25 sur ebay : ebay.fr/itm…993
Bonjour à tous,
Machine arrivée ce matin. Je vais déballer le joujou ce soir mais j'ai l'impression qu'il y a un peu de travail en perspective pour le montage ;-)
A bientôt pour les premières questions liées au montage de bête !
O.
Salut

Je te conseil de les metre sur les trous du Haut , car la vis a gauche pour regler la butée est pas super haute une fois mis en bas de l'axe Z
Pour la vis oui elle sont trop courte , mais le ventilateur a coté de l'alimentation n'a pas besoin de 4 vis 3 suffisent
et plus Il faut demonter l'extrudeur pour passer la vis dedans
perso j'ai mis les vis dans l'autre sens que sur ta photo , avec la tête dedans pour que sa ne tape pas dans l'extrudeur

J'ai le même soucis pour les axe moteur , il bouge que dans un sens au niveau de l'interface et ce bloque dans l'autre

Question vous avez une astuce pour faire que le plateau soit "plat" car quand je deplace la buse elle a tendance a vouloir frotté le coté droit de la plaque , j'ai beau jouer avec les vis a ressort mais ça reste bancale comme solution
zin27

Question vous avez une astuce pour faire que le plateau soit "plat" car … Question vous avez une astuce pour faire que le plateau soit "plat" car quand je deplace la buse elle a tendance a vouloir frotté le coté droit de la plaque , j'ai beau jouer avec les vis a ressort mais ça reste bancale comme solution



Aligner l'axe z, le plateau (avec plaque de verre), l'axe x et l'axe y avec des niveau à bulle ne suffit pas ?
J'essaye ce soir une fois rentré du boulot
Temps que j'y pense , la partie Bleu coller sur la plaque sert a quoi ?
c'est du bluetape, ça permet d'améliorer la première couche d'accroche. (je l'ai déjà flingué en baissant trop la tête de l'extrudeuse...faudrait que j'en achère)
Boubobo

Aligner l'axe z, le plateau (avec plaque de verre), l'axe x et l'axe y … Aligner l'axe z, le plateau (avec plaque de verre), l'axe x et l'axe y avec des niveau à bulle ne suffit pas ?



Non, ok c'est mieux avec tout de niveau, mais si l'axe horizontal de l'extrudeur n'est pas parfaitement parallèle au plateau ça va pas du tout aller...
Ce que j'ai fait :
- j'ai mis la machine en position initiale depuis les menus
- réglé petit à petit la vis de butée verticale jusqu'à ce que l'extrudeur touche légèrement le coin inférieur gauche du plateau avec la vitre (répéter en boucle le remise en position initiale jusqu'à arriver au bon réglage)
- ensuite il faut aller dans les menus et débrayer les moteurs
- déplacer le plateau sous l'extrudeur et régler les 4 vis de façon à ce qu'une feuille de papier passe tout juste entre les deux (ni plus, ni moins)
- répéter l'opération pour les 4 angles du plateau

Et là normalement c'est bon
je veux flasher le bootloader avec l'usbasp, mais je me retrouve comme un con face à la nappe de 10 cables, les cables sont en 1 rangée sur la nappe mais en 2 rangées sur le connecteur... Et je ne trouve pas l'ordre des cables par rapport au connecteur... Quelqu'un sait?
edit: bon, je fais plus simple, j'achete des cables dupont male femelle sur ebay, je suis livré d'ici la fin de la semaine normalement
edit2: j'ai rééssayé d'inverser des connecteurs toujours pareil
J'ai pas compris ta question Pluch

Si cela peut aider , le pilote c'étais bien installer mais il étais sur le Port5 ,du coup il ne la pas détecter , j'ai modifier pour le mettre sur le Port et la il a réagi
par contre le logiciel Cura que ce soit le chinois ou l'autre , je n'ai pas de bouton pour envoyer l'impression
j'ai bien allumer l'imprimante mais rien n'y fait
si vous avez une idée n’hésitez pas

Merci
essaye la combinaison de touche "ctrl" + "p" dans cura pour lancer l'impression.
Ce n'est pas grave pour ma question, ne t'en fais pas.
Mr_Pluch : Je n'ai jamais vu d'usbASP sur une seule ligne, tu es sur que c'est le bon adaptateur ?

Le pinout officiel est le suivant 15702129-puJC8, regarde si le tien à une série de GND d'un coté ?
Après de toute façon faudra broder pour le connecter sur la carte mère GT2560
15702129-kyZfb
donc autant attendre les dupont

zin27 : Le bluetape permet une meilleure adhésion de la première couche de filament que sur le verre. Personne n'imprime directement sur le verre (et SURTOUT PAS sur la plaque chauffante directement) : si la première couche ne colle pas bien, elle rétréci en refroidissant et déforme la base de la pièce imprimée.
J'ai commandé un ruban de kapton pour remplacer le bluetape, ya plein de recette alternative, mais une couche de fixation est nécessaire.
ce que j'ai vu jusqu'ici en fixation :
- bluetape
- kapton
- laque à cheveux
- colle en bombe
- BuildTak ( buildtak.eu/ )
- PEI (vidéo explication & démo youtube.com/wat…-dk )

Si je ne dis pas de bêtise (pas sur), Cura ne commande pas l'imprimante directement, il fait le fichier GCode à mettre sur la SD. Pour commander l'imprimante en USB il faut un soft comme pronterface : youtube.com/wat…MR4
Merci Boboubou !!!

Petite information , quand je vais dans les option de l'afficheur et que je desactive les stepers (les buté electronique donc)
les moteur ce deplace bien dans les deux sens
je peut aussi faire préchauffer l'extrudeur et le faire sortir du plastique
j'ai telecharger le logiciel Repetier-Host
Il ce conect bien a l'imprimante (elle fait un bruit de moteur et l'aficheur clignotte)
mais apres impossible de lui donner d'ordre d'impression
je vais devoir attendre de recevoir une reponse pour mon lecteur de Carte SD

Ps:Je suis en haute normandie , vous etes de qu'elle coin ? (cé plus simple d'en parler de vive voix si quelqu'un est dans le coin )
Désolé, je suis de l'autre coté du pays ! J'aimerais pouvoir parler de l'impression, mais mon montage n'en est pas encore là
Perso je souderais moi-même le lecteur SD, mais j'ai conscience que ce n'est pas la solution simple ni accessible à tlm
Je cherche a en recuperer un justement
ces le genre de truck que je garde toujours au cas ou , et quand je le cherche , cé introuvable ^^
J'ai des vieux lecteurs de carte flash (genre USB1) que je crucifierais sans hésiter pour recup ce lecteur de SD (oui je garde aussi plein de merdes).
Donc avec les vis de 20mm de ma réserve perso ça affleure tout juste, je me demande s'il y a la place pour 5mm de plus finalement, sinon je ferais comme tout le monde et j'inverserais des vis de 30.
15702334-ejUBw

Sinon voilà le tenseur "réparé" avec fil de fer et MOULT époxy. Je vais lui donner encore quelques heures de séchage avant de le mettre en tension.
15702334-hLdKD

Je me rend compte que le "montage" est terminé et qu'il me reste le câblage (j'ai tout débranché pour le faire tranquillement et en vérifiant avec toutes nos sources) et les réglages à faire. C'était pas compliqué, mais avec une doc juste et plus claire ça aurait été génial. Mais bon hein pour ce prix ...

Moi j'ai mis tout les câble avec le schéma donner par plush , j'ai juste pas trouver pour l'afficheur LCD si la nappe du dessus étais celui de la carte SD ou de l'afficheur
et j'ai regarder la vidéo et il me semble que la nappe du haut ,va sur le branchement du haut
et quand j'ai envoyer un mail pour mon abscence de lecteur de carte sd il avait mal compris ma question et m'a repondu
"Cher client, je vous remercie pour votre image, EXP 1 est LCD, EXP2 est SD, vous pouvez essayer, espérons que tout va bien, Belle journée.
Dear customer, thank you for your picture, EXP1 is LCD, EXP2 is SD, you can try, hope all goes well, Nice day."

du coup ça a répondu a ma question que j'avai pas demander

Ps: Il vont m'envoyer un autre LCD Asap , et en attendant je vais essayer d'en souder un
Il sont super réactif comme vendeur je trouve
Je cherche un auto bed leveling a connecter sur l'imprimante.
Vous avez des idée ?
J'ai repris la doc chinoise, google trad, plus check avec la doc de la carte GT2560, j'ai mis ça en français et ajouté des précisions (couleur des câbles, Nappe LCD, non connectés)

Si vous voyez des erreurs, merci de me les signaler, je les corrigerai

15702632-KKaHx

En PDF : stuff.knackes.com/dld…pdf

En ODT : stuff.knackes.com/dld…odt

Boubobo

J'ai repris la doc chinoise, google trad, plus check avec la doc de la … J'ai repris la doc chinoise, google trad, plus check avec la doc de la carte GT2560, j'ai mis ça en français et ajouté des précisions (couleur des câbles, Nappe LCD, non connectés)Si vous voyez des erreurs, merci de me les signaler, je les corrigeraiEn PDF : http://stuff.knackes.com/dld/201610/CTC_Prusa_I3_-_connections_0552DF89.pdfEn ODT : http://stuff.knackes.com/dld/201610/CTC_Prusa_I3_-_connections_27FF8009.odt


Excellent! Je l'ajoute sur le premier post, merci!

PS: si si on peut imprimer par Cura, il faut vraiment utiliser la combinaison de touche ctrl p , je l'ai utilisé pour lancer quelques tests sur les axes.
Première mise sous tension : pas top

Depuis le panneau de contrôle je peux faire aller les axes dans un sens mais pas l'autre (le firmware est clairement bugué : il ne propose pas de déplacement négatif et le chiffre n'est pris en compte que lorsque l'on tourne le bouton en sens inverse) Mon moteur Y de droite ne bouge pas, même en échangeant de prise avec celui de gauche, je viens de tester le câble et il est bon
Ah et apparemment dans ce mode (prepare) il en a rien a carrer des fin de course. Bon je vais tranquillement lire le reste de la doc avant de faire une connerie...
ces le passage dont je parler quand on désactive les steppers la il veut bien ce déplacer dans tout les sens
et non il en a rien a ciré des fin de courses
J'ai re-regardé les vidéo du post du début et j'ai comprims mon erreur : j'avais inversé axe Y et Z, mais pas partout.Maintenant mon Z (de bas en haut donc) bloque car celui de gauche est "grippé".

J'en ai profité pour corriger les docs de cablâge (couleur des fins de course Y & Z inversés) :

15702550-TB907
PDF : stuff.knackes.com/dld…pdf
ODT : stuff.knackes.com/dld…odt

Je suis pas chez moi je peut pas te répondre
par contre si tu a le temps tu pourrait me faire une photo de ton lecteur de carte SD ??
je vais en souder un en attendant mais j'ai peur de le mettre dans le mauvais sens
Voilà la mienne, fabriquée 2 mois avant, quand le quality check était sobre :
15702577-4I1tR

Bon mes cablâges sont maintenant correct, l'auto-home fonctionne à 80% : Axe X OK, Axe Y OK, mais l'Axe Z s'arrète à 1/3 de la hauteur.
Je pense savoir pourquoi : l'écartement des vis filetés verticales n'est pas constant ! (320mm en bas, 310 en ahut)
Maintenant il me reste à régler ce problème (je ne sais pas encore comment ni la cause) avant de tester l'extrudeur

Perso je tenais une tige pendant que je tourné l'autre a la main , une fois hors tension pour pas gêner les moteur
je pense que ces pas super conseiller mais bon
Je n'ai pas eu la patience d'attendre que mes cables dupont male femelle arrivent... j'en ai bricolé avec une vieille alimentation d'ordinateur, des cables dupont male male et du scotch d'électricien.
Je n'y croyais pas, pourtant ça à fonctionné!!!
J'ai réussi à dumper le firmware d'origine. Vous le trouverez ici (je vais le mettre sur le premier message du topic)
drive.google.com/ope…TUk

je vais volontairement écrire un second message pour faire une sorte de mini tuto.

Edit2: en tout cas ça n'a pas résolu mon problème de controle du moteur de l'extrusion, ça confirme que ce n'est pas un probleme logiciel
Attention: lors de la manipulation j'ai perdu l'affichage LCD, mais après pas mal de manipulation du firmware et des nappes, je pense que j'avais simplement inversé la nappe LCD et SD sans en être certain à 100% (vous réalisez donc la manipulation en connaissance de cause)

Si comme moi vous voulez mettre à jour le firmware de la GT2560 mais que vous avez un message d'erreur, c'est que le bootloader n'est pas bon.

Achetez un programmateur AVRusb:
ebay.fr/sch…t=0
et des fils dupont male femelle
ebay.fr/sch…t=0
Branchez le en usb et repéré la masse (GND) et le +5V (VTG) avec un voltmetre puis déduisez l'emplacement des autres pins
15702746-aAtvT
Connectez les pins correspondants aux pins suivants des ports LCD et SD de la carte GT2560

[image manquante]


installez le driver libusbk ou libsub-win32 et vérifiez qu'il est détecté dans votre gestionnaire de périphériques

Installez arduino et l'ouvrir.
Dans "fichier - exemples" sélectionner "arduinoisp"
Dans "outil - types de cartes" sélectionnez la 2560
Dans "outil - programmateurs" sélectionnez "USBasp"
Puis "outils - graver la séquence d'initialisation"

Maintenant vous pouvez faire une sauvegarde du firmware et en uploader un nouveau

Pour la sauvegarde:
Recherchez le fichier "avrdude.conf" dans le répertoire C:\Program Files (x86)\Arduino et placez le dans le répertoire C:\Program Files (x86)\Arduino\hardware\tools\avr\bin
ouvrir une invite de commande et tapez cette ligne pour dumper le firmware dans le répertoire c:\temp et en l'appelant "ctcprusa.hex"
avrdude -p m2560 -P COM13 -c stk500v2 -U flash:r:c:\temp\ctcprusa.hex:i

Pour uploader un nouveau, vous trouverez le Marlin pour i3 pro B ici:
geeetech.com/for…046
Attention, j'ai l'impression que le réglage des pas n'est plus correct! (mon imprimante est devenue beaucoup trop rapide à mon gout)

Mr_Pluch tu as testé l'imprimante entre le moment où tu as gravé le booloader et le moment où tu as flashé le firmware ? Parce que du coup ton dump n'est pas l'original vu que le bootloader y est déjà, je ne sais pas si l'imprimante peut marcher avec. Il aurais fallut dumper avec l'usbASP avant de graver le bootloader.
Mais le principal est que tu à réussi à uploader le firmware sans bricker ton imprimante (je sais pas si j'eût osé ). Reste à trouver les bons réglages dans Marlin.
A noter : le firmware geeetech n'est pas la version à jour de Marlin ( GitHub officiel : github.com/Mar…lin )

De mon coté j'ai toujours mon problème d'axe Z qui fait un trapèze / \ avec 1cm de large de moins en haut que en bas ... sauf... si j'enlève les équerres du haut qui supportent les barres lisses et filetées de l'axe Z.
Et comme chui un ouf gueudin, j'ai tenté une petite impression sans ces équerres, avec les axes Z juste tenus à la main :

15702843-Z15Ht

Pour un truc en pur freestyle, c'est plutôt pas mal : cet écrou M10 se visse effectivement sur les tiges filetées M10 de l'imprimante (celles du plateau).
Bon ça règle pas mon problème du cirque du soleil (trapèze tout ça) mais au moins j'ai put confirmer que tout le reste marchait au poil (chauffage, extrudeur, buses, moteurs, impression depuis la SD). L'impression a pris 4 minutes + le chauffage plaque et buse. L'idée de cet objet viens de la vidéo de montage du premier post : j'ai chargé la librairie dans openSCAD, choisi l'écrou M10, créé le STL, passé dans Slic3r (base 200x200mm, buse 0.4mm, fil 1.75mm) et copié le ficher gcode sur la sd, puis simplement fait [print from sd] et choisi mon fichier dans la liste.

C'est une victoire à la Pyrrhus, mais je vais commencer les recherches de solution pour ce problème plus tard, demain est un autre jour. Et ça aurais put être pire, j’aurais put mettre le feu à mon logement hein
Laisser un commentaire
Avatar
@
    Texte

    Discussions