CTC Prusa I3

Posté par Mr_Pluch le 07/10/2016 à 22h29

CTC Prusa I3

Le 07/10/2016 à 22h29

Le 21/11/2016 à 21h19

Bonsoir,

Ce topic est fait pour partager notre expérience sur l'imprimante 3D CTC Prusa I3 suite à ce deal: https://www.dealabs.com/bons-plans/imprimante-3d---prusa-i3-ctc-20x20x18-acrylique-reprap/264891.

contenu de la carte SD:
- https://www.dropbox.com/sh/jpug4th329c34r0/AAAXYGOt6RVDsIaZkPbfBLbQa?dl=0

Firmware CTC prusa i3 d'origine
- https://www.dropbox.com/sh/zzuqy9xwv8dqtmy/AABhunUZNaxDDMy9y7stLrXwa?dl=0
- Backup réalisé par Boubobo : https://www.dealabs.com/url/?e=6SxK67pSrYNZgD49Mw6aHeRPonintoY6pbZTX0BfdIm7W%2FYT%2FWHBsrnUG%2FXD2RlU9bZ00hsM7Ro%3D&w=all&l=comment&i=694808
- Firmware à jour (21/11/16) pour vis filetées M8 : http://stuff.knackes.com/dld/201611/Marlin_1_1_0_RC7_CTC_Prusa_Screw_0_1_D86F201C.zip
- Firmware à jour (21/11/16) pour vis hélicoïdales T8 : http://stuff.knackes.com/dld/201611/Marlin_1_1_0_RC7_CTC_Prusa_Heli_0_1_D5D32728.zip
- faire son propre backup :
Acheter cet accessoire : https://www.amazon.fr/gp/product/B01GCK3HDS/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1
[spoilerLigne de commande (depuis le dossier bin d'arduino) : avrdude -C ..\etc\avrdude.conf -p atmega2560 -c usbasp -U flash:r:"d:/GT25]60.hex":i[/spoiler]- restaurer un backup :
Pour le restaurer : avrdude -C ..\etc\avrdude.conf -p atmega2560 -c usbasp -U flash:w:"d:/GT2560.hex":i
- le câbler :
http://stuff.knackes.com/dld/201611/IMG_2016-11-13_11-24-32-1024_C4823720.jpg
- injecter le bootloader: https://www.dealabs.com/forums/le-bar/le-laboratoire-high-tech--informatique/ctc-prusa-i3/25480?post=702154&page=67


montage:
- https://www.youtube.com/watch?v=t1NRww33MzY
- https://www.youtube.com/watch?v=l4raiMEs_dk
- https://www.youtube.com/watch?v=BxP0bhk2Fcc

Le schema de montage de l'electronique de la documentation est faux, se référer à celui-ci:

- PDF : http://stuff.knackes.com/dld/201610/CTC_Prusa_I3_-_connections_D0B399E7.pdf
- ODT : http://stuff.knackes.com/dld/201610/CTC_Prusa_I3_-_connections_BA9BDB9E.odt

Régler la prusa:
- https://www.youtube.com/watch?v=KPmyv2FUSEc&feature=youtu.be

Pièces updates (à imprimer)
- Support alternatif pour l'axe Z: http://www.thingiverse.com/thing:1694197 ou http://www.thingiverse.com/thing:1409485
- Ventilateur pour refroidir le print: http://www.thingiverse.com/thing:1704920 ou http://www.thingiverse.com/thing:1531016 ou http://www.thingiverse.com/thing:1857313 (compatible avec le ventilateur B5015L12C NF1 12 V 0.08A https://fr.aliexpress.com/item/New-Original-Taiwan-TT-B5015L12C-NF1-12V-0-08A-3-lines-Graphics-card-cooling-fan/32719500926.html?spm=2114.30011508.3.1.6immRc&ws_ab_test=searchweb0_0,searchweb201602_2,searchweb201603_1&btsid=7f68fe54-379f-487d-8520-3b21c250feeb)
- Rigidifier l'axe Y: http://www.thingiverse.com/thing:1751317
- Cache alimentation: http://www.thingiverse.com/thing:1779851
- Poulie de remplacement: http://www.thingiverse.com/thing:1830392 ou http://www.thingiverse.com/thing:1849910
- Coupleur 5mm vers 8mm: http://www.thingiverse.com/thing:1848127
- patin anti wobble: http://www.thingiverse.com/thing:1849359
- Support ecran LCD déporté: http://www.thingiverse.com/thing:1853805
- Support endstop Z alternatif: http://www.thingiverse.com/thing:71488
- Support capteur bed leveling: http://www.thingiverse.com/thing:1810547
- Support capteur bel leveler BLTouch de Geetech : http://www.thingiverse.com/thing:1868404
- cache prise alimentation: http://www.thingiverse.com/thing:1778093



Pièces détachées & consommables:
- Capteur pour le Bed leveling - Geetech: http://www.geeetech.com/wiki/index.php/3DTouch_Auto_Leveling_Sensor ou https://fr.aliexpress.com/item/Free-Shipping-Geeetech-Auto-Leveling-Sensor-3D-Touch-for-3D-Printer-Improve-Printing-Precision/32761924885.html?spm=2114.13010208.99999999.264.e4MBhx&detailNewVersion=&categoryId=200003886 et http://tinyurl.com/jf8dlpm
- Coupleurs aluminium 5mm vers 8mm: http://tinyurl.com/hdqu6zd
- Tiges filetées Hélicoïdales T8x400mm avec vis: https://fr.aliexpress.com/item/1pcs-T8-8mm-screw-length-400mm-picth-2mm-lead-2mm-trapezoidal-screw-with-1pcs-brass-copper/32650839193.html?detailNewVersion=&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476695756111&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476695756&cn=15644&categoryId=100004516&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476695756111-08407-mEj2auM
- Ventilateur 12v : https://fr.aliexpress.com/item/Adroit-12V-2-Pin-40mm-Computer-Cooler-Small-Cooling-Fan-PC-Black-F-Heat-Sink-MAR26/32639720362.html?spm=2114.13010208.99999999.276.AWoV8I&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476781051201&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476781051&cn=15644&&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476781051202-03217-mEj2auM
- Roulements à bille pour le support de tiges filetées: https://fr.aliexpress.com/item/5PCS-ABEC-7-Deep-groove-ball-bearing-608ZZ-8X22X7-mm-bearing-steel-608-ZZ-skating-bearing/32543577721.html?spm=2114.13010608.0.0.KqsGSZ
- Extrudeuse en aluminium : https://fr.aliexpress.com/item/Free-Shipping-1-set-MK8-extruder-aluminum-block-DIY-kit-Makerbot-dedicated-single-nozzle-extrusion-head/32370075158.html?spm=2114.30011508.3.47.bc2ZuV&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476780765147&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476780765&cn=15644&ws_ab_test=searchweb0_0,searchweb201602_2_10065_10068_10069_10017_10080_10082_10081_10060_10061_10062_10056_10055_10037_10054_10059_10032_10078_10079_10077_10073_10072_10070_421_420_10052_10053_10050_10051,searchweb201603_3&btsid=5d098298-e9c8-47f5-8d45-76f8413398a3&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476780765147-01149-mEj2auM (Attention, il semblerait que le support de l'extrudeur soit incompatible)
Tube téflon: https://fr.aliexpress.com/item/1M-PTFE-Tube-Teflon-PiPe-to-J-head-hotend-RepRap-Rostock-Bowden-Extruder-for-3D-printer/32580984474.html?spm=2114.13010608.0.0.D1nI8t&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476780970871&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476780970&cn=15644&&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476780970871-04051-mEj2auM
- Chaîne de guidage de fils: https://fr.aliexpress.com/item/10-x-20mm-1M-Open-On-Both-Side-Plastic-Towline-Cable-Drag-Chain/2015816515.html?spm=2114.13010608.0.0.D1nI8t&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476780986673&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476780986&cn=15644&&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476780986673-05796-mEj2auM
- Poulies en aluminium : https://fr.aliexpress.com/item/GT2-Timing-Pulley-20-teeth-Alumium-Bore-5mm-fit-for-GT2-belt-Width-6mm-free/32629617890.html?spm=2114.13010608.0.0.pbDqWq&aff_platform=aaf&sk=mEj2auM%3A&cpt=1478204198414&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1478204198&cn=15644&detailNewVersion=&categoryId=200003886&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1478204198414-02258-mEj2auMspm=2114.13010608.0.0.D1nI8t&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476781011113&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476781011&cn=15644&&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476781011113-06433-mEj2auM
- Buse: https://fr.aliexpress.com/item/3D-printer-E3D-V6-V5-J-Head-M6-brass-nozzle-extruder-nozzles-0-2-0-25/32704261538.html?spm=2114.13010608.0.0.D1nI8t&aff_platform=aaf&sk=mEj2auM%3A&cpt=1476781141290&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476781141&cn=15644&&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476781141290-08629-mEj2auM
- Gorge de buse: https://fr.aliexpress.com/item/1PCS-RepRap-3D-Printer-M6-30mm-barrels-printer-nozzle-throat-with-Teflon-tube-1-75mm/32457910530.html?aff_platform=aaf&sk=mEj2auM%3A&cpt=1476781102548&af=191610&afref=&cv=12&dp=12%3A%3A191610%3A%3A%3A%3A%3A%3A1476781102&cn=15644&&aff_trace_key=585d9f698c3f4661a0c6c8a253dbaabc-1476781102548-08317-mEj2auM
- 3M ScotchBlue 2090-2A "BlueTape" : https://www.amazon.fr/dp/B00004Z4DU/
- plateau aluminium : http://www.ebay.fr/itm/262119045551?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT&rmvSB=true ou https://fr.aliexpress.com/af/prusa%252Baluminium/5.html?site=fra&g=y&SortType=price_asc&SearchText=prusa+aluminium&isAffiliate=y&initiative_id=SB_20161102073607&needQuery=n (attention, pas de support de roulements)
- Bobine PLA pas cher: http://www.ebay.fr/itm/321741800765?var=510646182707&redirect=mobile&rmvSB=true (couleurs rouge et orange fade, chauffe 195 à 2015°C)





Sites divers:
- calculer le nombre de steps/mm en cas de changement de tiges
- Rappel: motor step angle = 200 / microstepping = 1/16 / Tige de type M8
- http://prusaprinters.org/calculator/#stepspermmlead
- Guide visuel : http://www.makershop.fr/blog/ultimaker-le-guide-visuel/
- Parameter Slic3r: (ou au moins le moteur de l'extrudeur) http://velocirepraptor.com/parametrer-slic3r-le-guide-complet-en-un-seul-article/
- Visualisateur de GCode en ligne http://gcode.ws/
- Visualisateur de STL en ligne http://www.viewstl.com/
- Octoprint:
- http://octoprint.org/
- http://velocirepraptor.com/installer-un-serveur-dimpression-octoprint/
- http://velocirepraptor.com/utiliser-octoprint/
- aide sur la résolution de défaut d'impression : https://www.logre.eu/wiki/RepRap_printDoctor




Merci à tous pour votre participation.

779 commentaires

NOUVELLE REPONSE

Nombre de réponses par page

Ce paramètre s’applique automatiquement à l’ensemble des sujets.

Flux RSS des réponses

Page :

Mr_Pluch

Le 07/10/2016 à 22h42

#1 Signaler
Cette imprimante 3D est ma première, soyez donc un peu indulgent, je pars de 0.

J'ai trouvé le montage relativement simple, mis à part le fait qu'à certains moment je ne comprenais pas quelle partie de l'imprimante était concernée par le paragraphe...
Mais par contre je n'ai strictement rien compris au schéma électrique... du coup je me suis rabattu sur ce plan qui est beaucoup plus clair:
http://www.geeetech.com/wiki/index.php/GT2560

Mon imprimante a été livrée avec une vis longue manquante, j'ai du en retirer une du ventilateur de la carte électronique pour la mette sur la tête de l'extrudeuse.
Le support de la courroie de l'axe Y a été livrée cassée (celui en facade), la pièce est creuse, je conseille d'en imprimer un nouveau dès que possible.

Je rencontre un problème: rien ne sort de la buse... j'ai l'impression que le filament n'est pas entraîné.
J'ai coupé le filament en biseau comme conseillé, j'ai essayé avec une température de 200 à 240... Je ne comprends pas, peut être ai-je mal connecté quelque chose...,Quelqu'un à une idée?

yoyolo

Le 07/10/2016 à 23h08 (Modifié le 07/10/2016 à 23h12)

#2 Signaler
Comment est censé être entraîné le filament vers l'extruder ? le moteur l'actionnant se déclenche-t-il ?

Edit : est-ce que l'imprimante se met en mouvement (les axes bougent mais rien ne sort) ou rien ne bouge ?
Mr_Pluch

Le 07/10/2016 à 23h19 (Modifié le 07/10/2016 à 23h34)

#3 Signaler
Tous les axes bougent.
Je ne sais pas si le moteur qui l'actionne se déclenche, mais si j'essaie de forcer un peu sur le filament je sens quelques vibrations, je me demande presque si ce n'est pas monté à l'envers... je vais voir si je peux l'inverser
smg2

Le 07/10/2016 à 23h33

#4 Signaler
J'ai le même soucis pour les vis de la tête de l'extrudeuse :(
Mr_Pluch

Le 07/10/2016 à 23h35

#5 Signaler
Oui celles qui disent de mettre sont trop courtes, d'ou le fait de piquer celle du ventilateur de la carte :D

Pour mon problème de filament , le moteur pas à pas fait un coup en avant, un coup en arrière, c'est plutot logiciel ou matériel ça?
smg2

Le 08/10/2016 à 1h07

#6 Signaler
Il faut faire une MAJ du GT2560 ?
tenson22

Le 08/10/2016 à 9h47

#7 Signaler
Bonjour. J'ai également craqué pour ce deal,ma premiere imprimante 3D -_-' commande passée le 5/10. Je ne manquerai pas de laisser mes impressions.
Mr_Pluch

Le 08/10/2016 à 11h10 (Modifié le 08/10/2016 à 11h10)

#8 Signaler
Pas d'après la notice, mais si tu sais ou en trouver une, ça peut s'essayer....

J'ai essayé tout ça sans succès:
Régler le pololu avec un voltage de 1 à 1.10V comme trouvé dans des tutos.
intervertir le moteur (pas de problèmes pour controler les autres axes avec ce moteur)
intervertir le pololu (pas de problèmes pour controler les autres axes avec ce pololu)
intervertir le cable (pas de problèmes pour controler les autres axes avec ce cable)

J'ai l'impression que ma GT2560 à un problème...

bienvenue Tenson ;)
smg2

Le 08/10/2016 à 11h58 (Modifié le 08/10/2016 à 12h09)

#9 Signaler
Peluche

Le 08/10/2016 à 12h06

#10 Signaler
Salut. J'ai reçu mon colis ce matin. Je suis en plein montage et j'aurai besoin d'aide. Je suis à l'étape du montage de la pièce P mais je ne trouve pas le cable 19 ... :( Est-il censé être dans la boite ou est-il déjà monté sur un element ? Merci
smg2

Le 08/10/2016 à 12h16

#11 Signaler
Salut. J'ai reçu mon colis ce matin. Je suis en plein montage et j'aurai besoin d'aide. Je suis à l'étape du montage de la pièce P mais je ne trouve pas le cable 19 ... :( Est-il censé être dans la boite ou est-il déjà monté sur un element ? Merci

Ils est dans la boite. C'est le câble pour le moteur
Peluche

Le 08/10/2016 à 12h25 (Modifié le 08/10/2016 à 12h30)

#12 Signaler
Salut. J'ai reçu mon colis ce matin. Je suis en plein montage et j'aurai besoin d'aide. Je suis à l'étape du montage de la pièce P mais je ne trouve pas le cable 19 ... :( Est-il censé être dans la boite ou est-il déjà monté sur un element ? Merci

Ils est dans la boite. C'est le câble pour le moteur

Merci. Je pense avoir trouvé. Il était attaché avec l'étiquette "USB cord" noté 11, mais pas l'étiquette 19.
microbator

Le 08/10/2016 à 12h25

#13 Signaler
Pas d'après la notice, mais si tu sais ou en trouver une, ça peut s'essayer....

J'ai essayé tout ça sans succès:
Régler le pololu avec un voltage de 1 à 1.10V comme trouvé dans des tutos.
intervertir le moteur (pas de problèmes pour controler les autres axes avec ce moteur)
intervertir le pololu (pas de problèmes pour controler les autres axes avec ce pololu)
intervertir le cable (pas de problèmes pour controler les autres axes avec ce cable)

J'ai l'impression que ma GT2560 à un problème...

bienvenue Tenson ;)

Salut,

Perso, j'ai une imprimante Delta (donc pas du tout la même géométrie !), par contre, côté extrusion, le principe est le même.
Si, quand le moteur pas à pas d'extrusion tourne, tu sens des accoups et tu as l'impression qu'il essaye de faire avancer le filament, y arrive pas, et repart un peu en arrière, c'est a priori qu'il force trop.
Plusieurs solutions à ça :
-Buse/hotend pas assez chaud, le moteur pousse le filament qui ne fond pas et donc se bloque.
-Buse bouchée : peu probable si tu n'as pas imprimer avec, mais tu peux vérifier quand même si c'est propre.
-Le filament à un parcours avec trop de frottement : ça arrive de temps en temps si ton extrudeur est de type Bowden (avec un tuyau en PTFE de environ 50cm entre le moteur et le hotend), mais ici, d'après la photo, ça semble être du direct drive.

Plusieurs choses à essayer :
1- diminuer le réglage de force du système d'entrainement du filament : selon les extrudeurs, tu peux avoir une vis à serrer/desserer pour régler la force de la roue dentée du moteur sur le filament. Si la force exercée est trop grande, le moteur force de trop et n'arrive pas à faire bouger le filament, et il saute des pas (les petits accoups donc je parlais au dessus).
2- regarder, sans filament, si le moteur d'extrusion tourne bien
3- essayer de pousser le filament à la main (éventuellement, en enlevant le moteur d'extrusion) lorsque la buse est chaude pour voir si tu arrives à en faire sortir du plastique.


Tous cela devrait t'indiquer si le soucis vient du hotend (buse pas assez chaude ou bouchée) ou de la partie extrusion.
Bon courage !

Mr_Pluch

Le 08/10/2016 à 12h43

#14 Signaler
Super info, je te remercie!
Par contre le problème persiste même quand je démonte l'extrudeur et que le moteur tourne à vide :(
(donc normalement il y'a 0 forces)

smg2 : merci, j'ai mis tes liens dans le premier post
microbator

Le 08/10/2016 à 13h09

#15 Signaler
Effectivement, si après inversion des moteurs avec un moteur d'axe, t'as toujours le problème, c'est pas bon signe pour la carte... Je suppose que tu n'as qu'une seule sortie pour 1 extrudeur sur cette carte là ? (comme sur les 3/4 des cartes à pas cher fournies dans les kits).
Tu arrives à extruder "à la main" lorsque la buse est à température ? (220°C pour du PLA si ça sort pas c'est qu'il y à un problème :p)
Mr_Pluch

Le 08/10/2016 à 13h19

#16 Signaler
Il y'a de quoi mettre un second extrudeur, mais il ne fonctionne pas, surement pas activé dans le firmware...
Oui j'arrive à extruder à la main, en poussant, ça sort bien...

J'ai bien envie d'essayer le firmware Marlin pour la geeetech pro b: http://www.geeetech.com/forum/viewtopic.php?f=20&t=17046
Mais je ne sais pas si il est compatible à 100% et surtout je n'ai pas le firmware d'origine de la CTC pour le réinjecter en cas de problemes :/

J'ai contacté le vendeur ebay, il va me renvoyer la pièce imprimée cassée, mais il ne m'a pas encore répondu concernant le problème du moteur d'extrusion...
smg2

Le 08/10/2016 à 13h20

#17 Signaler
Comment bien reglé le bed ?
Je n'arrive pas a le reglé.
Mr_Pluch

Le 08/10/2016 à 13h22

#18 Signaler
Je n'en suis pas encore là :D
Mais je l'ai pré-réglé en compressant un peu les ressorts, en mettant la vis sur le capteur de fin de course lorsque la buse arrive à la hauteur d'une feuille de papier A4 aux quatre cotés du lit.
microbator

Le 08/10/2016 à 13h24

#19 Signaler
Normalement si c'est une carte à base d'arduino tu peux récupérer le firmware actuellement sur la carte.
Si tu as accès au firmware, tu as juste à désactiver l'extrudeur qui ne marche pas et à activer le second, normalement, ça devrait marcher.
Essaye de regarder si tu trouves plus d'infos sur cette carte sur des forums style reprap ou groupes facebook.
Mr_Pluch

Le 08/10/2016 à 13h28

#20 Signaler
Effectivement c'est à base d'arduino, je vais essayer tout ça.
Kvn

Le 08/10/2016 à 13h54

#21 Signaler
Effectivement c'est à base d'arduino, je vais essayer tout ça.

T'as pu t'en sortir avec le moteur pas à pas ? en gros, j'ai pas d'imprimante 3d mais je pratique régulièrement l’électronique... un moteur pas a pas a un certain nombre de fils et les signaux arrivant sur ces fils suivent un ordre précis, si un fil est inversé avec un autre il se peut qu'il se produise un tremblement car l'axe tournerait d'un pas dans un sans puis d'un pas dans l'autre sens immédiatement après (pour simplifier)

Est tu sur du câblage du moteur ?
Mr_Pluch

Le 08/10/2016 à 14h20

#22 Signaler
Non je n'ai pas encore réussi.
Tous les câbles sont identiques : noir vert rouge bleu coté électronique et noire rouge vert bleu coté moteur, et ils fonctionnent sur tous les moteurs sauf sur celui qui est branché sur le port du moteur de l'extrudeur (coté carte électronique). Et vu que j'ai validé que le pololu fonctionnait aussi avec les autres moteurs, c'est pour ça que je pense à soit un problème logiciel soit un problème sur la carte electronique.

Je n'arrive pas dans repetier à utiliser le second extrudeur, il est en erreur car du coup il n'y a pas de sonde de température pour le premier extrudeur |o

Mais le firmware est bien détecté comme un Marlin par Repetier, je vais m'assurer de faire un beau dump du firmware de base et voir pour le mettre à jour...
Il faut par contre que je note tous les réglages de base sur le FW actuel, mais vu que je suis une quiche je ne sais pas si je vais bien tout noter...
Grrrr


Vous y arrivez avec la votre vous?
microbator

Le 08/10/2016 à 14h42

#23 Signaler
Tu ne peux pas "remapper" les broches de l'extrudeur 1 sur l'extrudeur 2 et vice versa dans le firmware ?
Mr_Pluch

Le 08/10/2016 à 14h51

#24 Signaler
peut être, mais il faudrait au moins que je réussisse à dumper mon FW avant d'essayer d'en injecter un de modifié.
Mais ma commande ne fonctionne pas et je ne comprends pas pourquoi:
avrdude -p m2560 -P COM13 -c stk500v2 -U flash:r:c:\temp\ctcprusa.hex:i
microbator

Le 08/10/2016 à 14h51 (Modifié le 08/10/2016 à 14h53)

#25 Signaler
/****************************************************************************************
* Arduino Mega pin assignment
*
****************************************************************************************/
#if MOTHERBOARD == 3 || MOTHERBOARD == 33 || MOTHERBOARD == 34 || MOTHERBOARD == 35 || MOTHERBOARD == 77 || MOTHERBOARD == 67 || MOTHERBOARD == 68
#define KNOWN_BOARD 1

//////////////////FIX THIS//////////////
#ifndef __AVR_ATmega1280__
#ifndef __AVR_ATmega2560__
#error Oops! Make sure you have 'Arduino Mega' selected from the 'Tools -> Boards' menu.
#endif
#endif


// uncomment one of the following lines for RAMPS v1.3 or v1.0, comment both for v1.2 or 1.1
// #define RAMPS_V_1_3
// #define RAMPS_V_1_0


#if MOTHERBOARD == 33 || MOTHERBOARD == 34 || MOTHERBOARD == 35 || MOTHERBOARD == 77 || MOTHERBOARD == 67 || MOTHERBOARD == 68

#define LARGE_FLASH true

#if MOTHERBOARD == 77
#define X_STEP_PIN 54
#define X_DIR_PIN 55
#define X_ENABLE_PIN 38
#define X_MIN_PIN 3
#define X_MAX_PIN -1 //2 //Max endstops default to disabled "-1", set to commented value to enable.

#define Y_STEP_PIN 60
#define Y_DIR_PIN 61
#define Y_ENABLE_PIN 56
#define Y_MIN_PIN 14
#define Y_MAX_PIN -1 //15

#define Z_STEP_PIN 46
#define Z_DIR_PIN 48
#define Z_ENABLE_PIN 63
#define Z_MIN_PIN 18
#define Z_MAX_PIN -1

#define Y2_STEP_PIN 36
#define Y2_DIR_PIN 34
#define Y2_ENABLE_PIN 30

#define Z2_STEP_PIN 36
#define Z2_DIR_PIN 34
#define Z2_ENABLE_PIN 30

#define E0_STEP_PIN 26
#define E0_DIR_PIN 28
#define E0_ENABLE_PIN 24

#define E1_STEP_PIN 36
#define E1_DIR_PIN 34
#define E1_ENABLE_PIN 30

Dans le fichiers pins.h de marlin, je suppose qu'il n'y a qu'à inverser les numéros de pin :)

Edit: je n'ai jamais dumpé de firmware, je ne peux pas t'aider pour ça ! Désolé.
yoyolo

Le 08/10/2016 à 16h08

#26 Signaler
Quelqu'un saurait me donner la taille "exacte" de l'imprimante ? Ebay spécifie bien 36*38*43, mais ce n'est pas un cube xD
Ce serait pour fabriquer un caisson, le temps que je la reçoive...
Mr_Pluch

Le 08/10/2016 à 16h12 (Modifié le 08/10/2016 à 16h13)

#27 Signaler
C'est plutot 47cm de profondeur / 44cm de largeur / 45cm de hauteur

je deviens fou avec ce moteur pas à pas. Je suis pressé que vous la receviez pour me dire si vous avez le même problème.

Merci microbator, j'essaye dès que j'arrive à dumper...
Mr_Pluch

Le 08/10/2016 à 18h49 (Modifié le 08/10/2016 à 19h26)

#28 Signaler
Bon, j'y ai passé toute la journée, je crains qu'il n'y ait pas de bootloader sur la carte, ce qui expliquerait que je n'arrive ni à dumper ni à charger un FW...
Je crois que je vais tenter cette manip'...
http://forums.reprap.org/read.php?406,705081

Si je ne dis pas de bêtises, il faut ça: https://fr.aliexpress.com/item/USB-Wireless-Serial-Port-Module-Serial-Port-To-NRF24L01/32568901545.html?spm=2114.13010608.0.0.KxMGy7&detailNewVersion=&categoryId=400103
Coup de bol j'en ai que je n'ai pas encore utilisé,
Par contre je ne trouve pas la datasheet, alors je me base la dessus, j'ai repéré le VCC le GND alors j'en déduit les autres broches
http://arduino-info.wikispaces.com/file/view/24L01Pinout-800.jpg/243330999/24L01Pinout-800.jpg
Cependant je n'ai pas les bonnes fiches... il va falloir que je me démerde... avec les nappes fournies avec l'imprimante
Ce serait à connecter sur les ports LCD et SD de la GT2560:
http://www.geeetech.com/forum/viewtopic.php?p=27978#p27978

Mais je ne vais plus avoir de temps ce weekend :(

Je vous dirai si j'arrive à y mettre un bootloader pour ensuite charger le firmware de mon choix...

Je ne pensais pas rencontrer ce type de problèmes avec cette imprimante.
Boubobo

Le 08/10/2016 à 19h59 (Modifié le 08/10/2016 à 20h04)

#29 Signaler
J'ai reçu la mienne Samedi Matin, je ne l'ai pas encore sortie du carton, juste lut la doc en diagonale.

MR_Plush : non, il te vaut un adaptateur pour flasher un Atmel, ce que tu montres dans le lien est 'juste" un convertisseur série/usb qui n'a peut-être pas les bons signaux, et qui ne sera surement pas utilisable par avrdude. Il te faut un usbASP ( https://fr.aliexpress.com/item/Free-Shipping-2PCS-USBASP-10PIN-TO-6PIN-ADAPTER-New-USBASP-USBISP-AVR-Programmer-USB-ATMEGA8-ATMEGA128/1807010158.html ).
Le pinout d'un usbASP est le suivant :http://stuff.knackes.com/dld/201610/ScreenCap-20161008-195818_0CF4E7B2.jpg

/Edit 01/

Vu la disposition et la disponibilité des pins sur les Ports LCD et et SD, il va faloir se faire son propre adaptateur, le plus simple sera de juste relier l'usbASP à la GT2560 avec des fils dupont mâle-femelle (par exemple https://fr.aliexpress.com/item/40pcs-20cm-1p-1p-female-to-male-jumper-wire-Dupont-cable-for-Arduino-Breadboard/32658518783.html - les fils de a nappe sont fait pour être désolidarisés ).
zin27

Le 09/10/2016 à 0h14

#30 Signaler
Salut

j'ai acheter aussi l'imprimante
j'arrive a suivre les instruction jusqu'a la page 6 mais apres je capte pas tout :s
vous avez trouver une video pour vous aider ?
et pour fixer l'extrudeur sur la partie en plastique , il faut bien deux longue visse 7 ??
Car il m'en reste qu'une , et les visse 6 ne sont pas asser longue :p

Merci de votre aide
microbator

Le 09/10/2016 à 0h18

#31 Signaler
Bon, j'y ai passé toute la journée, je crains qu'il n'y ait pas de bootloader sur la carte, ce qui expliquerait que je n'arrive ni à dumper ni à charger un FW...
Je crois que je vais tenter cette manip'...
http://forums.reprap.org/read.php?406,705081

Si je ne dis pas de bêtises, il faut ça: https://fr.aliexpress.com/item/USB-Wireless-Serial-Port-Module-Serial-Port-To-NRF24L01/32568901545.html?spm=2114.13010608.0.0.KxMGy7&detailNewVersion=&categoryId=400103
Coup de bol j'en ai que je n'ai pas encore utilisé,
Par contre je ne trouve pas la datasheet, alors je me base la dessus, j'ai repéré le VCC le GND alors j'en déduit les autres broches
http://arduino-info.wikispaces.com/file/view/24L01Pinout-800.jpg/243330999/24L01Pinout-800.jpg
Cependant je n'ai pas les bonnes fiches... il va falloir que je me démerde... avec les nappes fournies avec l'imprimante
Ce serait à connecter sur les ports LCD et SD de la GT2560:
http://www.geeetech.com/forum/viewtopic.php?p=27978#p27978

Mais je ne vais plus avoir de temps ce weekend :(

Je vous dirai si j'arrive à y mettre un bootloader pour ensuite charger le firmware de mon choix...

Je ne pensais pas rencontrer ce type de problèmes avec cette imprimante.

Tu n'arrives pas à te connecter à la carte via ton PC ?
Tu as essayer sur une autre machine ? Perso, j'ai eu pas mal de soucis (impression qui s'arrête en cours, impossibilité de flasher, timeout etc...) et je n'arrivais pas à comprendre d'où ça venait. Finalement, j'ai juste changer le cable USB chinois (bleu) ultra bas de gamme par un neuf de meilleur qualité, et plus aucun soucis d'accès à la carte.
Mr_Pluch

Le 09/10/2016 à 0h54 (Modifié le 09/10/2016 à 1h00)

#32 Signaler
Merde je n'ai pas pensé au câble usb qui pourrait foirer.
J'arrive à lancer une impression mais pas à dumper ou flasher le firmware.
J'ai acheté l'usbasp sur remarques de boubobo. Comme ça quand je m'y remettrai j'aurai tout en main.
Oui j'ai essayé sur deux ordinateurs.

Zin27, j'ai rencontré les mêmes obstacles. Pour la vis du chariot j'ai piqué une du ventilateur de la carte électronique.
Pour l'étape 5 je n'ai pas le manuel sous les yeux, mais sinon tu as les vidéos du premier poste qui pourraient peut-être t'aider.
zin27

Le 09/10/2016 à 11h32

#33 Signaler
Merci de ta reponse
au niveau de la video ce que j'ai pas compris c'est qu'il utilise un acoupleur pour fixer les moteur a l'axe Z
hors dans le kit on a des petite gaine en plastique , et juste avant de les placer il y a un message qui dit de bien faire attention mais jai pas compris
"Before assembly, the first Z-axis screw M5 ends connect flexible coupling 30, is prohibited after blowing hot and then install the flexible coupling to the
M5 terminal end of the flexible coupling insert M5 depth of about 10mm. As
shown below:"

Jai préférer m'arreter la avan de faire une betise :p
tenson22

Le 09/10/2016 à 13h04

#34 Signaler
Pas d'après la notice, mais si tu sais ou en trouver une, ça peut s'essayer....

J'ai essayé tout ça sans succès:
Régler le pololu avec un voltage de 1 à 1.10V comme trouvé dans des tutos.
intervertir le moteur (pas de problèmes pour controler les autres axes avec ce moteur)
intervertir le pololu (pas de problèmes pour controler les autres axes avec ce pololu)
intervertir le cable (pas de problèmes pour controler les autres axes avec ce cable)

J'ai l'impression que ma GT2560 à un problème...

bienvenue Tenson ;)

http://prusaprinters.org/forums/topic/prusa-i3-motors-just-move-a-little-and-stop

Tu devrais peut être lire cette page. Bonne chance.
Boubobo

Le 09/10/2016 à 13h27

#35 Signaler
J'ai commencé l'assemblage ce matin, les instructions sont effectivement pleines d'erreurs mineures et laissent place à l'imagination dans certain cas, mais de toute façon, je m'arrête à la page 9 : je viens de voir qu'une pièce du plateau est arrivée cassée. Je viens de faire une demande ebay au vendeur pour qu'il me la renvoie.

Et malheureusement, comme il ne fournis pas les sources de cette pièce, je ne peut pas la refaire imprimer, je vais devoir attendre qu'elle arrive.
C'est dommage tout était plutôt bien emballé. Détail inutile : sur la plaque principale (A1) j’avais une vis et un écrou déjà monté... au mois ça fait un rab :D
Boubobo

Le 09/10/2016 à 13h56

#36 Signaler
Je voulais le recoller en attendant pour continuer l'assemblage, mais j'ai l'impression qu'il manque un roullement à bille d'un coté de l'engrenage blanc :



Avez-vous un roulement à bille des deux coté ou d'un seul comme le mien ?
zin27

Le 09/10/2016 à 13h58

#37 Signaler
Des deux coté il y a un roulement a bille sur le mien

J'ai reussi a tout monter
mais quand je fait bouger les axe avec le programe dedans , il descendent tous mais ne remonte pas
comme si il etais en buté dans un sens
sauf qu'il ny a de buée electronique due sur un sens de chaque axe nan ?

Boubobo

Le 09/10/2016 à 14h24 (Modifié le 09/10/2016 à 14h30)

#38 Signaler
Merci pour ta réponse, je ne retrouve pas le second roulement à bille donc pas la peine que je le colle.
J'ai déjà eut une réponse sur ebay, ils me renvoient la pièce, . Ils sont rapide !

pour ton souci : S'il ne remonte pas ça peut aussi être un pb de puissance ou de transmission (c'est plus facile de descendre que de tracter tout vers le haut).

/* Edit 1 */
Je viens de balader un gros aimant dans la box et paf le roullement manquant est de retour ! La voix de son maitre :D
Je vais essayer de recoller la pièce avec de la glue epoxy 2 composants, histoire de pas attendre la pièce du constructeur.

L'engrenage est asymétrique : quelqu'un peut me faire une photo du sien ou me dire exactement dans quel sens il doit aller dans la pièce rouge ?
Guilhem74

Le 09/10/2016 à 14h37 (Modifié le 09/10/2016 à 14h41)

#39 Signaler
Merde je n'ai pas pensé au câble usb qui pourrait foirer.
J'arrive à lancer une impression mais pas à dumper ou flasher le firmware.
J'ai acheté l'usbasp sur remarques de boubobo. Comme ça quand je m'y remettrai j'aurai tout en main.
Oui j'ai essayé sur deux ordinateurs.

Zin27, j'ai rencontré les mêmes obstacles. Pour la vis du chariot j'ai piqué une du ventilateur de la carte électronique.
Pour l'étape 5 je n'ai pas le manuel sous les yeux, mais sinon tu as les vidéos du premier poste qui pourraient peut-être t'aider.

Si tu intervertis un moteur de déplacement(Appelons A) et le moteur de l'extrudeur(Appelons B), ce dernier (B) tourne t'il cette fois ci correctement?

Edit : Si oui inverse l'ordre de tes cables. Appelons dans l'ordre 1-2-3-4 tes fils de moteurs, essaye de brancher 3-4-1-2
Mr_Pluch

Le 09/10/2016 à 15h37

#40 Signaler
@tension et @guilhem
Oui, le moteur mis sur le connecteur d'un axe, il tourne correctement.
Du coup je crois que je vais essayer ce que vous dites... Même si je ne comprends pourquoi il faudrait que je le fasse alors que les modèles de moteurs sont identiques. J'essaye demain.

Des que je peux je te poste une photo boubobo, si tu n'en as pas eu d'ici là.

J'ai essayé de recoller la pièce avec ce que j'ai... Superglue et colle epoxy.... Et bien ce n'est pas ce qu'il faut.
1 2 3 4 5 6
...

Aller page :

20

Laisser une réponse

Des champs obligatoires n’ont pas été remplis, ou l’ont été incorrectement.