RésoluImages dans les flux RSS + Feedly

Posté par Silveran le 01/12/2016 à 14h16

RésoluImages dans les flux RSS + Feedly

Le 01/12/2016 à 14h16

Le 02/12/2016 à 10h52

Bonjour,

depuis plusieurs jours, les flux RSS s'affichent mal dans Feedly (notamment les images)


J'utilise Chrome sur MacOS.
Je précise que cette erreur d'affichage se corrige quand j'ouvre un autre article RSS, et que je reviens sur le précédent...


J'imagine qu'il y a un léger bug dans le code HTML, j'ignore si je suis le seul dans ce cas.
Merci à tous ;)

29 commentaires

NOUVELLE REPONSE

Nombre de réponses par page

Ce paramètre s’applique automatiquement à l’ensemble des sujets.

Flux RSS des réponses

Dealhunter

Le 02/12/2016 à 10h52

#1 Signaler
Hello,

Merci pour l'info, nous enquêtons et tachons de corriger ce souci au plus vite ;).
Silveran

Le 05/12/2016 à 1h57

#2 Signaler
Pour expliquer le problème, il semble que l'image se charge avec un peu de latence et ne redimensionne pas le cadre autour d'elle, quand je reviens sur l'info, l'image étant chargée déjà, le cadre autour a la bonne taille cette fois. :/
adealistrateur

Le 05/12/2016 à 10h22

#3 Signaler
Est-ce que c'est bon désormais ?
Silveran

Le 05/12/2016 à 12h06

#4 Signaler
non malheureusement, toujours le même symptôme
adealistrateur

Le 05/12/2016 à 13h08

#5 Signaler
Feedly modifie le code html/CSS envoyé via les flux RSS, du coup je ne vois pas comment résoudre le problème :(.
Silveran

Le 05/12/2016 à 13h18

#6 Signaler
Ca fonctionnait nickel avec l'ancien code (à moins que Feedly ait changé), mais depuis quelques semaines, c'est perturbé de la sorte.
J'ai cru voir un essai avec l'image sortie du tableau HTML, l'image était bien visible là ;)
cha

Le 05/12/2016 à 14h21 (Modifié le 05/12/2016 à 14h26)

#7 Signaler
D'ailleurs à ce sujet, pourriez vous ajouter l'image du deal en <enclosure> dans les noeuds <item> des RSS ?
En vous remerciant
Sthocs

Le 05/12/2016 à 14h41

#8 Signaler
Merci, problème réglé de mon côté.
J'avais également un problème avec certaines images depuis la mise à jour du flux RSS (mise à jour qui a rendu le paramètre "limit" obsolète)
Les images non carrées étaient étirées en hauteur, mais quand je dis étiré, c'était des centaines de milliers de pixels de hauteur.
Je viens de refresh et je vois les images rectangulaires normalement maintenant, merci !
adealistrateur

Le 05/12/2016 à 15h17

#9 Signaler
D'ailleurs à ce sujet, pourriez vous ajouter l'image du deal en <enclosure> dans les noeuds <item> des RSS ?
En vous remerciant
J'ai ajouté la balise <enclosure> pour les images, est-ce que c'est ok de ton coté ?
cha

Le 05/12/2016 à 15h30

#10 Signaler
D'ailleurs à ce sujet, pourriez vous ajouter l'image du deal en <enclosure> dans les noeuds <item> des RSS ?
En vous remerciant
J'ai ajouté la balise <enclosure> pour les images, est-ce que c'est ok de ton coté ?

Merci c'est parfait :) Quelle réactivité !!!
namron

Le 05/12/2016 à 15h34

#11 Signaler
perso, depuis 15h ce n'est plus comme avant sous thunderbird
j'ai l'image en pièce jointe de mon coté
ça ne me gène pas, mais c'est inhabituel :)
adealistrateur

Le 05/12/2016 à 15h40

#12 Signaler
perso, depuis 15h ce n'est plus comme avant sous thunderbird
j'ai l'image en pièce jointe de mon coté
ça ne me gène pas, mais c'est inhabituel :)
C'est dû à l'ajout de la balise <enclosure>. Je ne sais pas si c'est très pertinent de l'avoir ajouté c'est normalement pour les fichiers multimédia...
cha

Le 05/12/2016 à 15h43 (Modifié le 05/12/2016 à 15h45)

#13 Signaler
Beaucoup s'en servent de cette façon, par exemple ici mais je peux t'en lister d'autres si tu veux : http://www.nextinpact.com/rss/bonsplans.xml
Çà permet notamment d'afficher de jolies notifications, aucun aggrégateur ne va à ma connaissance extraire au pif une des images dans le HTML / content pour agrémenter un popup de notif.
adealistrateur

Le 05/12/2016 à 16h08

#14 Signaler
Beaucoup s'en servent de cette façon, par exemple ici mais je peux t'en lister d'autres si tu veux : http://www.nextinpact.com/rss/bonsplans.xml
Çà permet notamment d'afficher de jolies notifications, aucun aggrégateur ne va à ma connaissance extraire au pif une des images dans le HTML / content pour agrémenter un popup de notif.
Et du coup avec ce que je viens d'ajouter (enclosure) ça fonctionne ?
cha

Le 05/12/2016 à 16h30

#15 Signaler
Dans mon client, parfaitement bien, je t'en remercie :)
adealistrateur

Le 05/12/2016 à 16h34

#16 Signaler
Dans feedly j'ai toujours un souci, certaines images sont incorrectes au niveau de la liste :
Silveran

Le 05/12/2016 à 16h36

#17 Signaler
En tout cas, les images semblent s'afficher nickel après leur chargement désormais moi ! Bien joué ;)
adealistrateur

Le 05/12/2016 à 16h43

#18 Signaler
En tout cas, les images semblent s'afficher nickel après leur chargement désormais moi ! Bien joué ;)
Je n'ai rien changé normalement xD xD
Silveran

Le 05/12/2016 à 16h44

#19 Signaler
WTF... Avec Feedly faut se méfier, y'a leur cache, ce que je sais, c'est que les articles les plus récents s'affichent nickel, mais ceux vieux de plus de 8h ont encore le bug ;)
Silveran

Le 05/12/2016 à 17h28

#20 Signaler
Ca marche bien aussi avec les derniers articles, félicitations, ne touche plus à rien xD
Merci beaucoup pour ton travail et ta réactivité (si j'avais su, j'aurais signalé ça depuis plus longtemps) ;)
n0va

Le 05/12/2016 à 21h00

#21 Signaler
Je rencontre le problème des miniatures qui ne s'affichent pas depuis quelques heures. J'utilise FeedDemon.
cha

Le 05/12/2016 à 21h51 (Modifié le 05/12/2016 à 22h01)

#22 Signaler
Yop

@adealistrateur

J'ai jeté un oeil au problème FeedDeamon.

Il faut changer ça

<td valign='center' >
<table cellpadding="0" cellspacing="0" border="0" align='center'>
<tbody>
<tr align='center' >
<td style="padding-bottom:10px;" ><img src="https://static.dealabs.com/deal_image/5845cda66f7996.11930698.png" width="160" height="160"/></td>
</tr>
</tbody>
</table>
</td>

En ça :

<td valign='center' align='center' style="padding-bottom:10px;">
<img src="https://static.dealabs.com/deal_image/5845cda66f7996.11930698.png" width="160" height="160"/>
</td>

Réinstaller ce logiciel m'a rappelé de bons vieux souvenirs, mais ça fait 3 ans qu'il est abandonné ;)
n0va

Le 05/12/2016 à 22h38

#23 Signaler
oui ils l'ont abandonné, et du coup est passé en gratuit pour la version Pro.
adealistrateur

Le 06/12/2016 à 9h20 (Modifié le 06/12/2016 à 9h21)

#24 Signaler
Je rencontre le problème des miniatures qui ne s'affichent pas depuis quelques heures. J'utilise FeedDemon.
Ça devrait désormais refonctionner non ?

@cha : Merci pour l'info, pour le moment j'ai remis une partie du code comme avant, ça devrait être mieux.
n0va

Le 06/12/2016 à 18h51 (Modifié le 06/12/2016 à 23h30)

#25 Signaler
@adealistrateur
Je viens d'essayer, mais malheureusement il n'y aucune évolution positive. Aucune miniature en vue. :(
adealistrateur

Le 07/12/2016 à 8h20

#26 Signaler
C'est bizarre car je viens de remettre une partie du code comme avant :(.

Je vais voir ce que je peux faire de plus.
n0va

Le 07/12/2016 à 15h45

#27 Signaler
Merci, d'y jeter encore un oeil.
adealistrateur

Le 08/12/2016 à 15h49

#28 Signaler
J'ai effectué quelques modifications, qu'est ce que ça donne de votre coté ?
n0va

Le 08/12/2016 à 19h47

#29 Signaler
Ça Marche ! Merci beaucoup, c'est nickel.

Laisser une réponse

Des champs obligatoires n’ont pas été remplis, ou l’ont été incorrectement.